I am getting error "Port 9000 is already in use error during installation"

I am getting error "Port 9000 is already in use error during installation"

Introduction

Leapwork Controllers runs at port 9000. Before installing Leapwork to a machine, the Leapwork installer checks the availability of port 9000.

The "Port 9000 is already in use" message is shown due to the following reasons:

Below popup is shown during installation if the port is already in use.

Resolution

The above-mentioned issue can be resolved in the following ways:

  1. If an earlier version of Leapwork is using port 9000: Uninstall Leapwork and then re-install. To uninstall Leapwork, do the following:
  1. In case another application is using port 9000: Try installing the latest version of Leapwork and update the port number to a new value during the installation (Example: Update Automation Controller port to 9001 as shown below).

If the issue continues, please contact our Priority Support.